股票爱好者

您现在的位置是:首页 > 股票公式 > 飞狐公式

飞狐公式

飞狐周日MACD指标公式

2020-01-02 飞狐公式
上市日期年:REF(YEAR,BARSCOUNT(C)-1),linethick0,COLORRED;月:REF(MONTH,BARSCOUNT(C)-1),linethick0,COLORYELLOW;日:REF(DAY,BARSCOUNT(C)-1),linethick0,COLORCYAN;DIFF:=(EMA(CLOSE,12)-EMA(CLOSE,...

上市日期年:REF(YEAR,BARSCOUNT(C)-1),linethick0,COLORRED;
月:REF(MONTH,BARSCOUNT(C)-1),linethick0,COLORYELLOW;
日:REF(DAY,BARSCOUNT(C)-1),linethick0,COLORCYAN;
DIFF :=( EMA(CLOSE,12) - EMA(CLOSE,26))*2;
DEA := EMA(DIFF,9);
MACD := 2*(DIFF-DEA), COLORSTICK;
DIFFA := "macd.diff#week";
DEAA := "macd.dea#week";
FILLRGN(DIFFA>DEAA,DIFFA,DEAA),COLOR3232F0;FILLRGN(DIFFAPARTLINE(DIFF>REF(DIFF,1),DIFF),linethick2,colorred;
PARTLINE(DIFFPARTLINE(DIFF>REF(DIFF,1)AND REF(DIFF,1)>0,DIFF),linethick2,colorred;
PARTLINE(DEA>REF(DEA,1),DEA),coloryellow;
PARTLINE(DEASTICKLINE(MACD,0,MACD,6,0 ),COLOR00AAFF;
STICKLINE(MACD,0,MACD,6.6,0 ),COLOR00BBFF;
STICKLINE(MACD,0,MACD,4.4,0 ),COLOR00CCFF;
STICKLINE(MACD,0,MACD,3.3,0 ),COLOR00DDFF;
STICKLINE(MACD,0,MACD,2.2,0 ),COLOR00EEFF;
STICKLINE(MACD,0,MACD,1.1,0 ),COLOR00FFFF;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,6,0 ),COLOR0000AA;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,6.6 ,0 ),COLOR0011BB;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,4.4,0 ),COLOr0022CC;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,3.3 ,0 ),COLOR0033DD;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,2.2 ,0 ),COLOR0044EE;
STICKLINE(MACD>=ref(MACD,1)and MACD>0,0,MACD,1.1 ,0 ),COLOR0055FF;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,6,0 ),COLOR00AAFF;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,6.6 ,0 ),COLOR00BBFF;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,4.4,0 ),COLOR00CCFF;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,3.3,0 ),COLOR00DDFF;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,2.2 ,0 ),COLOR00EEFF;
STICKLINE(MACD>ref(MACD,1)and MACD<0,0,MACD,1.1 ,0 ),COLOR00FFFF;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,6,0 ),COLORFF7700;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,6.6 ,0 ),COLORFF8811;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,4.4,0 ),COLORFFAA22;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,3.3 ,0 ),COLORFFBB33;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,2.2 ,0 ),COLORFFDD44;
STICKLINE(MACD<=ref(MACD,1)and MACD<0,0,MACD,1.1 ,0 ),COLORFFFF55;
PARTLINE(DIFFA>REF(DIFFA,1),DIFFA),linethick1,colorRED;
PARTLINE(DIFFAPARTLINE(DIFFA>REF(DIFFA,1)AND REF(DIFFA,1)>0,DIFFA),linethick1,colorred;
PARTLINE(DEAA>REF(DEAA,1),DEAA),color00DDDD;
PARTLINE(DEAADRAWICON(cross(DIFFA,DEAA),DIFFA*1,10);
DRAWICON(cross(DEAA,DIFFA),DEAA*1,11);

 

飞狐周日MACD指标公式的选股公式如下: