股票爱好者

您现在的位置是:首页 > 股票公式 > 通达信公式

通达信公式

通达信薛斯通道和布林线主图指标公式

2019-09-29 通达信公式
{参数D1是找大底的参数,默认60,只适用于大盘,如果想用于个股,需要单独定制调整}D1:=60;{薛斯通道1加2}N:=13;N1:=102;M:=7;VAR2:=CLOSE*VOL;VAR3:=EMA((EXPMA(VAR2,3)/EXPMA(VOL,3)+EXPMA(VAR2,6)/EXPMA(VOL,6)+EXPMA(VAR2,12)/EXPMA(V...

{参数D1是找大底的参数,默认60,只适用于大盘,如果想用于个股,需要单独定制调整}
D1:=60;
{薛斯通道1加2}
N:=13;N1:=102;M:=7;
VAR2:=CLOSE*VOL;
VAR3:=EMA((EXPMA(VAR2,3)/EXPMA(VOL,3)+EXPMA(VAR2,6)/EXPMA(VOL,6)
+EXPMA(VAR2,12)/EXPMA(VOL,12)+EXPMA(VAR2,24)/EXPMA(VOL,24))/4,N);
SUP:1.06*VAR3,COLORLIGREEN;
SDN:VAR3*0.94,COLORLIGREEN;
VAR4:=EXPMA(CLOSE,9);
LUP:EXPMA(VAR4*1.14,5),COLORCBCBFF;
LDN:EXPMA(VAR4*0.86,5),COLORCBCBFF;
{DRAWBAND(LUP,RGB(0,0,130),LDN,RGB(0,0,130));
DRAWBAND(SUP,RGB(130,81,0),SDN,RGB(130,81,0));}
{STICKLINE(1,LUP,LDN,0.1,0),COLORFAD39D;
STICKLINE(1,SUP,SDN,0.1,0),COLOR005082;}
DRAWBAND(LUP,RGB(31,111,181),LDN,RGB(31,111,181));
DRAWBAND(SUP,RGB(157,211,250),SDN,RGB(157,211,250));
AAX:=MA((2*CLOSE+HIGH+LOW)/4,5);
通道1:=AAX*N1/100;{,LINETHICK2,COLORYELLOW; }
通道2:=AAX*(200-N1)/100;{,LINETHICK2,COLORYELLOW; }
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
通道3:(1+M/100)*DD;{,LINETHICK2,COLORMAGENTA;}
通道4:(1-M/100)*DD;{,LINETHICK2,COLORMAGENTA;}
{DRAWICON(L<=SDN AND L<=LDN AND L<=通道2 AND L<=通道4 AND O<=C,L*0.97,1);
DRAWICON(H>=SUP AND H>=LUP AND H>=通道1 AND H>=通道3,H*1.03,2);}
{布林加均线加BBI}
MID : MA(CLOSE,26),COLORFFFFFF,POINTDOT;
UPPER: MID + 2*STD(CLOSE,26),COLORFFFFFF,POINTDOT;
LOWER: MID - 2*STD(CLOSE,26),COLORFFFFFF,POINTDOT;
{STICKLINE((UPPER-LOWER)DRAWBAND(UPPER,RGB(161,94,0),LOWER,RGB(161,94,0));
MID1 : MA(CLOSE,26),COLORFFFFFF,POINTDOT;
UPPER1: MID1 + 2*STD(CLOSE,26),COLORFFFFFF,POINTDOT;
LOWER1: MID1 - 2*STD(CLOSE,26),COLORFFFFFF,POINTDOT;
MA5:MA(CLOSE,5),COLOR0220D2;
MA60:MA(CLOSE,60),COLOR00AAAA,LINETHICK2;
MA120:MA(CLOSE,120),COLORFF44FF,LINETHICK3;
MA250:MA(CLOSE,250),COLORFF0000,LINETHICK3;
BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLOR00FF00;
{通道31:(1+M/100)*DD,LINETHICK2,COLORMAGENTA;
通道41:(1-M/100)*DD,LINETHICK2,COLORMAGENTA;}
{重绘K线}
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);