股票爱好者

您现在的位置是:首页 > 股票教程 > 公式技巧

公式技巧

两周内高低画跟踪水平线的公式

2019-10-03 公式技巧
编写要求:两周内高低画一条跟踪水平线:两周以外的不要显示,只显示最近两周内,根据时间而跟随移动。类似10天高低点画跟踪水平线一样。解答:起:=CROSS(CONST(SUM(WEEKDAY=1,0))-1=SUM(WEEKDAY=1,0),0.5);天数:=BARSLAST(起);高:=CONST(IF(ISLASTBAR,HHV(H,天数+1),0));高...

编写要求:

两周内高低画一条跟踪水平线:两周以外的不要显示,只显示最近两周内,根据时间而跟随移动。类似10天高低点画跟踪水平线一样。

解答:

起:=CROSS(CONST(SUM(WEEKDAY=1,0))-1=SUM(WEEKDAY=1,0),0.5);
天数:=BARSLAST(起);
高:=CONST(IF(ISLASTBAR,HHV(H,天数+1),0));
高点:REF(H,BARSLAST(H=高 AND 天数>=0));
低:=CONST(IF(ISLASTBAR,LLV(L,天数+1),0));
低点:REF(L,BARSLAST(L=低 AND 天数>=0));